12.2. العمل مع جدول البيانات الوصفية

يعرض جدول البيانات الوصفية معلومات عن معالم الطبقة المحددة. يمثل كل صف في الجدول معلمًا (بشكل هندسي أو بدونه)، ويحتوي كل عمود على معلومة محددة عن المعلم. يمكن البحث عن المعالم في الجدول وتحديدها ونقلها بل وتحريرها.

12.2.1. تمهيد: الجداول المكانية وغير المكانية

يتيح لك QGIS تحميل طبقات مكانية وغير مكانية. يشمل هذا حاليًا الجداول التي يدعمها GDAL والنصوص المحددة بفواصل، إضافة إلى مزوّدات PostgreSQL و MS SQL Server و SpatiaLite و Oracle. تُدرج جميع الطبقات المحمّلة في لوحة Layers. ويحدد كون الطبقة مكانية أم لا ما إذا كان بإمكانك التفاعل معها على الخريطة.

يمكن استعراض الجداول غير المكانية وتحريرها باستخدام عرض جدول البيانات الوصفية. كما يمكن استخدامها للبحث في قيم الحقول؛ فمثلًا يمكنك استخدام أعمدة جدول غير مكاني لتعريف قيم البيانات الوصفية، أو مدى القيم المسموح بها، لتُضاف إلى طبقة متجهية معينة أثناء الرقمنة. ألقِ نظرة أقرب على عنصر واجهة التحرير في القسم خصائص نموذج البيانات الوصفية لمعرفة المزيد.

12.2.2. التعرّف على واجهة جدول البيانات الوصفية

لفتح جدول البيانات الوصفية لطبقة متجهية، فعّل الطبقة بالنقر عليها في لوحة الطبقات. ثم من القائمة الرئيسية Layer اختر openTable Open Attribute Table. يمكن أيضًا النقر بزر الفأرة الأيمن على الطبقة واختيار openTable Open Attribute Table من القائمة المنسدلة، أو النقر على زر openTable Open Attribute Table في شريط أدوات البيانات الوصفية. إذا كنت تفضل الاختصارات، فإن F6 يفتح جدول البيانات الوصفية، و Shift+F6 يفتحه مصفّى على المعالم المحددة، و Ctrl+F6 يفتحه مصفّى على المعالم المرئية.

سيفتح هذا نافذة جديدة تعرض البيانات الوصفية لمعالم الطبقة (figure_attributes_table). بحسب الإعداد في قائمة Settings ► Options ► Data sources، يُفتح جدول البيانات الوصفية في نافذة مثبّتة أو في نافذة عادية. يُعرض العدد الكلي لمعالم الطبقة وعدد المعالم المحددة/المصفّاة حاليًا في عنوان جدول البيانات الوصفية، وكذلك ما إذا كانت الطبقة محدودة مكانيًا.

../../../_images/vectorAttributeTable.png

شكل 12.73 جدول البيانات الوصفية لطبقة المناطق

توفر الأزرار في أعلى نافذة جدول البيانات الوصفية الوظائف التالية:

جدول 12.1 الأدوات المتاحة

أيقونة

Label

غرض

الاختصار الافتراضي

toggleEditing

تبديل وضع التحرير

تفعيل وظائف التحرير

Ctrl+E

multiEdit

تبديل وضع التحرير المتعدد

تحديث حقول متعددة لعدد كبير من المعالم

saveEdits

حفظ التعديلات

حفظ التعديلات الحالية

refresh

إعادة تحميل الجدول

newTableRow ► ([1])

إضافة معلم

إضافة معلم جديد بدون شكل هندسي

► newTableRow

إضافة معلم عبر جدول البيانات الوصفية

يُدرج صفًا فارغًا جديدًا في جدول البيانات الوصفية لتعبئته

► formSelect

إضافة معلم عبر نموذج البيانات الوصفية

يفتح نموذج البيانات الوصفية للمعلم لإدخال البيانات

deleteSelectedFeatures

حذف المعالم المحددة

إزالة المعالم المحددة من الطبقة

editCut

قص المعالم المحددة إلى الحافظة

Ctrl+X

copySelected

نسخ المعالم المحددة إلى الحافظة

Ctrl+C

editPaste

لصق المعالم من الحافظة

إدراج معالم جديدة من المعالم المنسوخة

Ctrl+V

expressionSelect

تحديد المعالم باستخدام تعبير

selectAll

تحديد الكل

تحديد جميع المعالم في الطبقة

Ctrl+A

invertSelection

عكس التحديد

عكس التحديد الحالي في الطبقة

Ctrl+R

deselectActiveLayer

إلغاء تحديد الكل

إلغاء تحديد جميع المعالم في الطبقة الحالية

Ctrl+Shift+A

filterMap

تصفية/تحديد المعالم باستخدام النموذج

Ctrl+F

selectedToTop

نقل المحدد إلى الأعلى

نقل الصفوف المحددة إلى أعلى الجدول

panToSelected

تحريك الخريطة إلى الصفوف المحددة

Ctrl+P

zoomToSelected

تكبير الخريطة إلى الصفوف المحددة

Ctrl+J

newAttribute

حقل جديد

إضافة حقل جديد إلى مصدر البيانات

Ctrl+W

deleteAttribute

حذف حقل

إزالة حقل من مصدر البيانات

editTable

تنظيم الأعمدة

إظهار/إخفاء الحقول من جدول البيانات الوصفية

calculateField

فتح حاسبة الحقول

تحديث حقل لعدة معالم دفعة واحدة

Ctrl+I

conditionalFormatting

التنسيق الشرطي

تفعيل تنسيق الجدول

dock

إرساء جدول البيانات الوصفية

يتيح إرساء جدول البيانات الوصفية أو فصله

actionRun

Actions

يعرض الإجراءات المرتبطة بالطبقة

تنبيه

تبعًا لصيغة البيانات ولمكتبة GDAL المبنية مع إصدار QGIS لديك، قد لا تتوفر بعض الأدوات.

يوجد أسفل هذه الأزرار شريط الحساب السريع للحقول (لا يُفعَّل إلا في وضع التحرير)، الذي يتيح تطبيق العمليات الحسابية بسرعة على جميع معالم الطبقة أو على جزء منها. يستخدم هذا الشريط التعبيرات نفسها التي تستخدمها calculateField Field Calculator (انظر تحرير قيم البيانات الوصفية).

12.2.2.1. عرض الجدول مقابل عرض النموذج

يوفر QGIS وضعين للعرض لتسهيل التعامل مع البيانات في جدول البيانات الوصفية:

  • يعرض openTable Table view قيم معالم متعددة في شكل جدولي، إذ يمثل كل صف معلمًا ويمثل كل عمود حقلًا. يتيح لك النقر بالزر الأيمن على رأس العمود ضبط طريقة عرض الجدول، بينما يتيح النقر بالزر الأيمن على خلية التفاعل مع المعلم.

    يدعم جدول البيانات الوصفية في وضع عرض الجدول التمرير باستخدام Shift+Mouse Wheel للتبديل بين التمرير العمودي والأفقي. ويمكن تحقيق ذلك أيضًا باستخدام لوحة اللمس بدلًا من الفأرة في macOS.

  • يعرض formView Form view معرّفات المعالم في لوحة أولى، ويعرض في اللوحة الثانية البيانات الوصفية للمعرّف الذي نقرت عليه فقط. توجد في أعلى اللوحة الأولى قائمة منسدلة يمكن من خلالها تحديث "المعرّف" باستخدام سمة (Columns ►) أو Expression. وتتيح لك القائمة Sort... ► فرز المعرّفات المعروضة By display name (ascending) أو By display name (descending) أو By custom expression. كما تتضمن القائمة المنسدلة آخر 10 تعبيرات لإعادة استخدامها. يستخدم عرض النموذج إعدادات حقول الطبقة (انظر خصائص نموذج البيانات الوصفية).

    يمكنك التنقل بين معرّفات المعالم باستخدام الأسهم أسفل اللوحة الأولى، وتتحدث البيانات الوصفية للمعالم في اللوحة الثانية أثناء تنقلك. ويمكنك أيضًا تحديد المعلم النشط في لوحة الخريطة أو الانتقال إليه بالضغط على أي من الأزرار في الأسفل:

    • highlightFeature Highlight current feature إذا كان ظاهرًا في لوحة الخريطة

    • panTo Automatically pan to current feature

    • zoomTo Zoom to current feature

يمكنك التبديل من وضع إلى آخر بالنقر على الأيقونة المقابلة في أسفل يمين نافذة الحوار.

يمكنك أيضًا تحديد وضع Default view عند فتح جدول البيانات الوصفية من القائمة Settings ► Options ► Data Sources. ويمكن أن يكون 'Remember last view' أو 'Table view' أو 'Form view'.

../../../_images/attribute_table_views.png

شكل 12.74 جدول البيانات الوصفية في عرض الجدول (أعلى) مقابل عرض النموذج (أسفل)

12.2.2.2. ضبط الأعمدة

انقر بالزر الأيمن على رأس عمود في عرض الجدول للوصول إلى أدوات تساعدك في التحكم في:

تغيير عرض الأعمدة

يمكن ضبط عرض الأعمدة بالنقر بالزر الأيمن على رأس العمود واختيار أحد الخيارين:

  • Set width... لإدخال القيمة المطلوبة. تُعرض القيمة الحالية افتراضيًا في عنصر الواجهة

  • Set all column widths... لضبطها على القيمة نفسها

  • Autosize لتغيير حجم العمود ليلائم محتواه على أفضل وجه.

  • Autosize all columns

يمكن أيضًا تغيير حجم العمود بسحب الحد الموجود على يمين عنوانه. يُحفظ الحجم الجديد للعمود في الطبقة، ويُستعاد عند فتح جدول البيانات الوصفية في المرة التالية.

في إعدادات مصادر البيانات، يمكنك اختيار checkbox Autosize all columns by default when opening attribute table، مما يجعل "Autosize All Columns" هو العرض الافتراضي في كل مرة تُفتح فيها جداول البيانات الوصفية في QGIS.

إخفاء الأعمدة وتنظيمها وتفعيل الإجراءات

بالنقر بالزر الأيمن على رأس عمود، يمكنك اختيار Hide column لإخفائه من جدول البيانات الوصفية (في وضع "عرض الجدول"). وللتحكم المتقدم، اضغط على الزر editTable Organize columns... في شريط أدوات نافذة الحوار، أو اختر Organize columns... من القائمة السياقية لرأس العمود.

في نافذة الحوار الجديدة، يمكنك:

  • تفعيل/إلغاء تفعيل الأعمدة التي تريد إظهارها أو إخفاءها: سيختفي العمود المخفي من كل نسخ نافذة جدول البيانات الوصفية إلى أن تستعيده صراحةً. ويمكنك أيضًا:

    • اختيار Show All لعرض جميع الحقول (الأعمدة) والإجراءات في الجدول

    • اختيار Hide All لإخفاء جميع الحقول (الأعمدة) والإجراءات في الجدول

    • استخدام Toggle selection لعكس ظهور الأعمدة المحددة حاليًا. ويمكنك استخدام تركيبات لوحة المفاتيح لتحديد أعمدة متعددة.

  • سحب العناصر وإفلاتها لإعادة ترتيب الأعمدة في جدول البيانات الوصفية. لاحظ أن هذا التغيير يخص طريقة عرض الجدول ولا يغيّر ترتيب الحقول في مصدر بيانات الطبقة

  • إضافة عمود افتراضي جديد باسم Actions يعرض في كل صف قائمة منسدلة أو قائمة أزرار بالإجراءات المفعّلة. انظر خصائص الإجراءات لمزيد من المعلومات حول الإجراءات.

فرز الصفوف

يمكن فرز الصفوف حسب أي عمود بالنقر على رأس العمود. يشير سهم صغير إلى ترتيب الفرز (السهم المتجه إلى الأسفل يعني قيمًا تنازلية من الصف العلوي نزولًا، والمتجه إلى الأعلى يعني قيمًا تصاعدية من الصف العلوي نزولًا). ويمكنك أيضًا فرز الصفوف باستخدام الخيار Sort... من القائمة السياقية لرأس العمود وكتابة تعبير. فمثلًا، لفرز الصفوف باستخدام أعمدة متعددة يمكنك كتابة concat(col0, col1).

في عرض النموذج، يمكن فرز معرّف المعالم باستخدام الخيار sort Sort by preview expression.

لاحظ أن فرز الصفوف يؤثر فقط في طريقة عرض الجدول ولا يغيّر ترتيب المعالم في مصدر بيانات الطبقة.

نصيحة

الفرز بناءً على أعمدة من أنواع مختلفة

قد تؤدي محاولة فرز جدول البيانات الوصفية بناءً على أعمدة من النوعين النصي والرقمي إلى نتيجة غير متوقعة، لأن التعبير concat("USE", "ID") يعيد قيمًا نصية (أي 'Borough105' < 'Borough6'). يمكنك تجاوز ذلك باستخدام، مثلًا، concat("USE", lpad("ID", 3, 0)) الذي يعيد 'Borough105' > 'Borough006'.

12.2.2.3. تنسيق خلايا الجدول باستخدام الشروط

يمكن استخدام إعدادات التنسيق الشرطي لإبراز المعالم التي تريد التركيز عليها في جدول البيانات الوصفية، باستخدام شروط مخصصة على:

  • الشكل الهندسي للمعلم (مثل تحديد المعالم متعددة الأجزاء، أو ذات المساحة الصغيرة، أو الواقعة ضمن امتداد خريطة محدد...)؛

  • أو قيمة الحقل (مثل مقارنة القيم بحد معين، أو تحديد الخلايا الفارغة، أو القيم المكررة، ...).

يمكنك تفعيل لوحة التنسيق الشرطي بالنقر على الزر conditionalFormatting Conditional formatting في أعلى يمين نافذة البيانات الوصفية في عرض الجدول (لا يعمل في عرض النموذج).

تتيح اللوحة الجديدة للمستخدم إضافة قواعد جديدة لتنسيق عرض radioButtonOnField أو radioButtonOffFull row. تفتح إضافة قاعدة جديدة نموذجًا لتحديد:

  • اسم القاعدة؛

  • شرط يستخدم أيًّا من دوال منشئ التعبيرات؛

  • التنسيق: يمكن اختياره من قائمة تنسيقات معرّفة مسبقًا أو إنشاؤه بناءً على خصائص مثل:

    • ألوان الخلفية والنص؛

    • استخدام أيقونة؛

    • الخط العريض، أو المائل، أو المسطَّر، أو المشطوب؛

    • الخط.

../../../_images/attribute_table_conditional_formating.png

شكل 12.75 التنسيق الشرطي لجدول البيانات الوصفية

12.2.3. التفاعل مع المعالم في جدول البيانات الوصفية

12.2.3.1. تحديد المعالم

في عرض الجدول، يعرض كل صف في جدول البيانات الوصفية سمات معلم فريد في الطبقة. يؤدي تحديد صف إلى تحديد المعلم، وبالمثل يؤدي تحديد معلم في لوحة الخريطة (في حالة الطبقات ذات الأشكال الهندسية) إلى تحديد الصف في جدول البيانات الوصفية. وإذا تغيّرت مجموعة المعالم المحددة في لوحة الخريطة (أو جدول البيانات الوصفية)، يُحدَّث التحديد في جدول البيانات الوصفية (أو لوحة الخريطة) تبعًا لذلك.

يمكن تحديد الصفوف بالنقر على رقم الصف في الجانب الأيسر منه. ويمكن تمييز صفوف متعددة بالضغط مع الاستمرار على المفتاح Ctrl. ويمكن إجراء تحديد متصل بالضغط مع الاستمرار على المفتاح Shift والنقر على عدة رؤوس صفوف في الجانب الأيسر منها، فتُحدَّد جميع الصفوف الواقعة بين موضع المؤشر الحالي والصف الذي نقرت عليه. لا يؤدي تحريك موضع المؤشر في جدول البيانات الوصفية بالنقر على خلية في الجدول إلى تغيير تحديد الصفوف. كما أن تغيير التحديد في لوحة الخريطة الرئيسية لا يحرّك موضع المؤشر في جدول البيانات الوصفية.

في عرض النموذج لجدول البيانات الوصفية، تُعرَّف المعالم افتراضيًا في اللوحة اليسرى بقيمة الحقل المعروض لها (انظر خصائص العرض). يمكن استبدال هذا المعرّف باستخدام القائمة المنسدلة في أعلى اللوحة، إما باختيار حقل موجود أو باستخدام تعبير مخصص. ويمكنك أيضًا اختيار فرز قائمة المعالم من القائمة المنسدلة.

انقر على قيمة في اللوحة اليسرى لعرض البيانات الوصفية للمعلم في اللوحة اليمنى. لتحديد معلم، عليك النقر داخل رمز المربع على يسار المعرّف. يتحول الرمز افتراضيًا إلى اللون الأصفر. وكما في عرض الجدول، يمكنك تحديد معالم متعددة باستخدام تركيبات لوحة المفاتيح المذكورة سابقًا.

إلى جانب تحديد المعالم بالفأرة، يمكنك إجراء تحديد آلي بناءً على البيانات الوصفية للمعلم باستخدام الأدوات المتاحة في شريط أدوات جدول البيانات الوصفية، مثل (انظر القسم التحديد التلقائي وما يليه لمزيد من المعلومات وحالات الاستخدام):

  • expressionSelect Select By Expression...

  • formSelect Select Features By Value...

  • deselectActiveLayer Deselect All Features from the Layer

  • selectAll Select All Features

  • invertSelection Invert Feature Selection.

يمكن أيضًا تحديد المعالم باستخدام النماذج.

12.2.3.2. تصفية المعالم

بعد تحديد معالم في جدول البيانات الوصفية، قد ترغب في عرض هذه السجلات فقط في الجدول. يمكن فعل ذلك بسهولة باستخدام العنصر Show Selected Features من القائمة المنسدلة في أسفل يسار نافذة جدول البيانات الوصفية. توفر هذه القائمة المرشحات التالية:

  • openTable Show All Features

  • openTableSelected Show Selected Features - مماثل لاستخدام Open Attribute Table (Selected Features) من القائمة Layer أو من Attributes Toolbar أو الضغط على Shift+F6

  • openTableVisible Show Features visible on map - مماثل لاستخدام Open Attribute Table (Visible Features) من القائمة Layer أو من Attributes Toolbar أو الضغط على Ctrl+F6

  • openTableInvalid Show Features with Failing Constraints - تُصفّى المعالم لعرض تلك التي لا تستوفي القيود فقط. وتبعًا لكون القيد غير المستوفى صارمًا أو مرنًا، تُعرض قيم الحقول المخالفة في خلايا برتقالية داكنة أو فاتحة على التوالي.

  • openTableEdited Show Edited and New Features - مماثل لاستخدام Open Attribute Table (Edited and New Features) من القائمة Layer أو من Attributes Toolbar

  • Field Filter - يتيح للمستخدم التصفية بناءً على قيمة حقل: اختر عمودًا من القائمة، واكتب قيمة أو اخترها، ثم اضغط Enter للتصفية. بعد ذلك تُعرض في جدول البيانات الوصفية المعالم المطابقة للتعبير num_field = value أو string_field ilike '%value%' فقط. ويمكنك تفعيل checkbox Case sensitive لتكون المطابقة أقل تساهلًا مع النصوص.

  • filterMap Advanced filter (Expression) - يفتح نافذة حوار منشئ التعبيرات، حيث يمكنك إنشاء تعبيرات معقدة لمطابقة صفوف الجدول. فمثلًا، يمكنك تصفية الجدول باستخدام أكثر من حقل. عند تطبيقه، يظهر تعبير التصفية في أسفل النموذج.

  • handleStoreFilterExpressionChecked Stored filter expressions ►: اختصار إلى التعبيرات المحفوظة المستخدمة كثيرًا لتصفية جدول البيانات الوصفية.

يمكن أيضًا تصفية المعالم باستخدام النماذج.

ملاحظة

لا تؤدي تصفية السجلات من جدول البيانات الوصفية إلى استبعاد المعالم من الطبقة؛ إذ تُخفى مؤقتًا من الجدول فقط، ويمكن الوصول إليها من لوحة الخريطة أو بإزالة المرشح. أما المرشحات التي تُخفي المعالم من الطبقة فعلًا، فاستخدم لها Query Builder.

نصيحة

تحديث تصفية مصدر البيانات باستخدام Show Features Visible on Map

عندما تكون المعالم المعروضة في جدول البيانات الوصفية مقيدة مكانيًا، لأسباب تتعلق بالأداء، بامتداد لوحة الخريطة عند فتح الجدول (انظر خيارات مصادر البيانات لمعرفة الطريقة)، فإن اختيار Show Features Visible on Map عند امتداد جديد للوحة الخريطة يحدّث هذا التقييد المكاني.

12.2.3.3. حفظ تعبيرات التصفية

يمكن حفظ التعبيرات التي تستخدمها لتصفية جدول البيانات الوصفية لاستدعائها لاحقًا. عند استخدام Field Filter أو Advanced Filter (expression)، يُعرض التعبير المستخدم في عنصر واجهة نصي في أسفل نافذة جدول البيانات الوصفية. اضغط على handleStoreFilterExpressionUnchecked Save expression with text as name بجوار المربع لحفظ التعبير في المشروع. ويتيح الضغط على القائمة المنسدلة بجوار الزر حفظ التعبير باسم مخصص (Save expression as...). عند عرض تعبير محفوظ، يُفعَّل الزر handleStoreFilterExpressionChecked وتتيح لك قائمته المنسدلة Edit the expression واسمه إن وُجد، أو Delete stored expression.

تُحفظ تعبيرات التصفية في المشروع وتكون متاحة من خلال القائمة Stored filter expressions في جدول البيانات الوصفية. وهي تختلف عن تعبيرات المستخدم التي تتشاركها جميع مشاريع ملف تعريف المستخدم النشط.

12.2.3.4. تصفية المعالم وتحديدها باستخدام النماذج

يؤدي النقر على filterMap Filter/Select features using form أو الضغط على Ctrl+F إلى تبديل نافذة جدول البيانات الوصفية إلى عرض النموذج واستبدال كل عنصر واجهة بنسخته الخاصة بالبحث.

من هذه النقطة فصاعدًا، تكون وظيفة هذه الأداة مماثلة لما هو موصوف في تحديد المعالم حسب القيمة، حيث تجد وصفًا لجميع العوامل وأوضاع التحديد.

../../../_images/tableFilteredForm.png

شكل 12.76 جدول البيانات الوصفية بعد تصفيته بنموذج التصفية

عند تحديد المعالم أو تصفيتها من جدول البيانات الوصفية، يوجد زر Filter features يتيح تعريف المرشحات وتنقيحها. يؤدي استخدامه إلى تفعيل الخيار Advanced filter (Expression) وعرض تعبير التصفية المقابل في عنصر واجهة نصي قابل للتحرير في أسفل النموذج.

إذا كانت هناك معالم مصفّاة مسبقًا، يمكنك تنقيح المرشح باستخدام القائمة المنسدلة بجوار الزر Filter features. والخيارات هي:

  • Filter within ("AND")

  • Extend filter ("OR")

لمسح المرشح، اختر الخيار Show all features من القائمة المنسدلة في أسفل اليسار، أو امسح التعبير وانقر على Apply أو اضغط Enter.

12.2.3.5. إجراءات إضافية على المعالم

تتوفر للمستخدمين عدة إمكانات للتعامل مع المعالم في جدول البيانات الوصفية. انقر بالزر الأيمن على خلية، ويمكنك:

  • تحديد جميع المعالم باستخدام Select all (Ctrl+A)؛

  • نسخ محتوى خلية إلى الحافظة باستخدام Copy cell content؛

  • استخدام Zoom to feature دون الحاجة إلى تحديده مسبقًا؛

  • استخدام Pan to feature دون الحاجة إلى تحديده مسبقًا؛

  • استخدام Flash feature لإبرازه في لوحة الخريطة؛

  • استخدام Open form: يبدّل جدول البيانات الوصفية إلى عرض النموذج مع التركيز على المعلم الذي نقرت عليه.

  • عرض قائمة الإجراءات المفعّلة سابقًا في التبويب Layer properties ► Actions.

../../../_images/copyCellContent.png

شكل 12.77 زر نسخ محتوى الخلية

إذا أردت استخدام البيانات الوصفية في برامج خارجية (مثل Excel أو LibreOffice أو تطبيق ويب مخصص)، فحدد صفًا واحدًا أو أكثر واستخدم الزر copySelected Copy selected rows to clipboard أو اضغط Ctrl+C. علاوة على ذلك، يمكنك في القائمة Settings ► Options ► Data Sources تحديد الصيغة التي يُلصق بها باستخدام الخيار Copy features as. لمزيد من التفاصيل انظر إعدادات مصادر البيانات.

12.2.4. تحرير قيم البيانات الوصفية

لتعديل البيانات في جدول البيانات الوصفية، عليك أولًا تبديل الطبقة إلى وضع التحرير. اضغط على الزر toggleEditing Toggle Editing. وتبعًا لنوع الشكل الهندسي للطبقة وحالة الحافظة، تُفعَّل بضع أدوات إضافية في شريط الأدوات العلوي لجدول البيانات الوصفية.

يمكن بعد ذلك تحرير قيم البيانات الوصفية عن طريق:

  • كتابة القيمة الجديدة مباشرة في الخلية، سواء كان جدول البيانات الوصفية في عرض الجدول أو عرض النموذج. وبذلك تُجرى التغييرات خلية تلو خلية ومعلمًا تلو معلم؛

  • استخدام حاسبة الحقول: لتحديث حقل موجود أو حقل سيُنشأ، دفعة واحدة لمعالم متعددة. ويمكن استخدامها لإنشاء حقول افتراضية؛

  • استخدام شريط الحساب السريع للحقول: مثل ما سبق، لكن للحقول الموجودة فقط؛

  • أو استخدام وضع التحرير المتعدد: لتحديث حقول متعددة لمعالم متعددة دفعة واحدة.

يتيح لك وضع الطبقة في وضع التحرير أيضًا استخدام editPaste Paste features from clipboard (Ctrl+V) و editCut Cut selected rows to clipboard (Ctrl+X) أو deleteSelectedFeatures Delete selected features. لمزيد من التفاصيل انظر قص المعالم ونسخها ولصقها.

12.2.4.1. استخدام حاسبة الحقول

يتيح لك الزر calculateField Field Calculator في جدول البيانات الوصفية إجراء عمليات حسابية بناءً على قيم البيانات الوصفية الموجودة أو على دوال معرّفة، مثلًا لحساب طول المعالم أو مساحتها. ويمكن استخدام النتائج لتحديث حقل موجود، أو كتابتها في حقل جديد (يمكن أن يكون حقلًا افتراضيًا).

تتوفر حاسبة الحقول في أي طبقة تدعم التحرير. عند النقر على أيقونة حاسبة الحقول تُفتح نافذة الحوار (انظر شكل 12.78). إذا لم تكن الطبقة في وضع التحرير، تُعرض رسالة تحذير، وسيؤدي استخدام حاسبة الحقول إلى وضع الطبقة في وضع التحرير قبل إجراء الحساب.

استنادًا إلى نافذة منشئ التعبيرات، توفر نافذة حاسبة الحقول واجهة متكاملة لتعريف تعبير وتطبيقه على حقل موجود أو حقل جديد. لاستخدام نافذة حاسبة الحقول، عليك أن تختار ما إذا كنت تريد:

  1. تطبيق الحساب على الطبقة كاملة أو على المعالم المحددة فقط

  2. إنشاء حقل جديد للحساب أو تحديث حقل موجود.

../../../_images/fieldcalculator.png

شكل 12.78 حاسبة الحقول

إذا اخترت إضافة حقل جديد، فعليك إدخال اسم الحقل ونوعه (عدد صحيح، أو عدد حقيقي، أو تاريخ، أو نص)، وعند الحاجة الطول الكلي للحقل ودقته. فمثلًا، إذا اخترت طولًا للحقل قدره 10 ودقة قدرها 3، فهذا يعني أن لديك 7 أرقام قبل الفاصلة و3 أرقام للجزء العشري.

يوضح المثال القصير التالي كيفية عمل حاسبة الحقول عند استخدام التبويب Expression. نريد حساب الطول بالكيلومتر لطبقة railroads من مجموعة بيانات QGIS التجريبية:

  1. حمّل ملف Shapefile railroads.shp في QGIS واضغط على openTable Open Attribute Table.

  2. انقر على toggleEditing Toggle editing mode وافتح نافذة calculateField Field Calculator.

  3. فعّل مربع الاختيار checkbox Create a new field لحفظ نتائج الحساب في حقل جديد.

  4. اضبط Output field name على length_km

  5. اختر Decimal number (real) في Output field type

  6. اضبط Output field length على 10 و Precision على 3

  7. انقر نقرًا مزدوجًا على $length في المجموعة Geometry لإضافة طول الشكل الهندسي إلى مربع التعبير في حاسبة الحقول (ستبدأ برؤية معاينة للناتج، حتى 60 حرفًا، أسفل مربع التعبير تتحدث آنيًا أثناء بناء التعبير).

  8. أكمل التعبير بكتابة / 1000 في مربع التعبير في حاسبة الحقول وانقر على OK.

  9. يمكنك الآن أن تجد حقلًا جديدًا باسم length_km في جدول البيانات الوصفية.

12.2.4.2. إنشاء حقل افتراضي

الحقل الافتراضي هو حقل قائم على تعبير يُحسب آنيًا، أي أن قيمته تتحدث تلقائيًا بمجرد تغيّر أي من المعاملات التي يعتمد عليها. يُطبَّق التعبير على جميع معالم الطبقة ويُضبط مرة واحدة؛ فلا تحتاج بعد ذلك إلى إعادة حساب الحقل في كل مرة تتغير فيها القيم الأساسية. فمثلًا، قد ترغب في استخدام حقل افتراضي إذا احتجت إلى حساب المساحة أثناء رقمنة المعالم، أو إلى حساب المدة بين تواريخ قد تتغير تلقائيًا (مثل استخدام الدالة now()).

يُنشأ الحقل الافتراضي من خلال نافذة calculateField Field calculator ويتبع الإجراء نفسه المتبع مع الحقول العادية. فقط تذكّر تفعيل الخيار checkbox Create virtual field واستخدام نوع حقل متوافق مع البيانات التي سيولدها تعبيرك.

يُحرَّر الحقل الافتراضي من خلال التبويب sourceFields Fields في نافذة خصائص الطبقة (انظر خصائص الحقول). يظهر التعبير الذي يعرّف الحقل في العمود Comment، ويؤدي الضغط على الزر expression بجواره إلى فتح نافذة محرر التعبيرات لتحديثه.

ملاحظة

استخدام الحقول الافتراضية

  • لا يمكن جعل الحقل افتراضيًا إلا عند إنشائه.

  • الحقول الافتراضية ليست دائمة في البيانات الوصفية للطبقة، أي أنها تُحفظ وتتوفر فقط في ملف المشروع الذي أُنشئت فيه.

12.2.4.3. استخدام شريط الحساب السريع للحقول

بينما تتوفر حاسبة الحقول دائمًا، لا يظهر شريط الحساب السريع للحقول أعلى جدول البيانات الوصفية إلا إذا كانت الطبقة في وضع التحرير. وبفضل محرك التعبيرات، يوفر وصولًا أسرع لتحرير حقل موجود:

  1. اختر الحقل المراد تحديثه من القائمة المنسدلة.

  2. املأ مربع النص بقيمة، أو بتعبير تكتبه مباشرة أو تبنيه باستخدام زر التعبير expression.

  3. انقر على الزر Update All أو Update Selected أو Update Filtered حسب حاجتك.

../../../_images/fieldcalculatorbar.png

شكل 12.79 شريط الحساب السريع للحقول

12.2.4.4. تحرير حقول متعددة

على خلاف الأدوات السابقة، يتيح وضع التحرير المتعدد تحرير سمات متعددة لمعالم مختلفة في الوقت نفسه. عند تبديل الطبقة إلى وضع التحرير، تصبح إمكانات التحرير المتعدد متاحة:

  • باستخدام الزر multiEdit Toggle multi edit mode من شريط الأدوات داخل نافذة جدول البيانات الوصفية؛

  • أو باختيار القائمة Edit ► multiEdit Modify attributes of selected features.

ملاحظة

على خلاف الأداة الموجودة في جدول البيانات الوصفية، يوفر لك الخيار Edit ► Modify Attributes of Selected Features نافذة حوار مشروطة (modal) لإدخال تغييرات البيانات الوصفية. لذلك يلزم تحديد المعالم قبل التنفيذ.

لتحرير حقول متعددة دفعة واحدة:

  1. حدد المعالم التي تريد تحريرها.

  2. من شريط أدوات جدول البيانات الوصفية، انقر على الزر multiEdit. سيؤدي ذلك إلى تبديل نافذة الحوار إلى عرض النموذج. ويمكن أيضًا تحديد المعالم في هذه الخطوة.

  3. تظهر في الجانب الأيمن من جدول البيانات الوصفية حقول المعالم المحددة (وقيمها). وتظهر عناصر واجهة جديدة بجوار كل حقل تعرض حالة التحرير المتعدد الحالية:

    • multiEditMixedValues يحتوي الحقل على قيم مختلفة للمعالم المحددة. يُعرض فارغًا وسيحتفظ كل معلم بقيمته الأصلية. يمكنك إعادة تعيين قيمة الحقل من القائمة المنسدلة لعنصر الواجهة.

    • multiEditSameValues لجميع المعالم المحددة القيمة نفسها لهذا الحقل، وستُحفظ القيمة المعروضة في النموذج.

    • multiEditChangedValues حُرِّر الحقل وستُطبَّق القيمة المدخلة على جميع المعالم المحددة. تظهر رسالة في أعلى نافذة الحوار تدعوك إلى تطبيق التعديل أو إعادة تعيينه.

    يتيح لك النقر على أي من عناصر الواجهة هذه إما ضبط القيمة الحالية للحقل أو إعادتها إلى القيمة الأصلية، أي أنه يمكنك التراجع عن التغييرات حقلًا بحقل.

    ../../../_images/attribute_multiedit.png

    شكل 12.80 تحرير حقول معالم متعددة

  4. أجرِ التغييرات التي تريدها على الحقول.

  5. انقر على Apply changes في نص الرسالة العلوي أو على أي معلم آخر في اللوحة اليسرى.

ستُطبَّق التغييرات على جميع المعالم المحددة. وإذا لم يُحدَّد أي معلم، يُحدَّث الجدول بأكمله بتغييراتك. تُجرى التعديلات كأمر تحرير واحد، لذا فإن الضغط على undo Undo سيتراجع عن تغييرات البيانات الوصفية لجميع المعالم المحددة دفعة واحدة.

ملاحظة

لا يتوفر وضع التحرير المتعدد إلا للنماذج المولّدة تلقائيًا ونماذج السحب والإفلات (انظر تخصيص نموذج لبياناتك)؛ ولا تدعمه النماذج ذات واجهات المستخدم المخصصة.

12.2.5. استكشاف البيانات الوصفية للمعالم باستخدام أداة التعريف

يمكن استخدام الأداة identify Identify features لعرض جميع البيانات الوصفية لمعلم في لوحة الخريطة. إنها طريقة سريعة لعرض جميع البيانات والتحقق منها دون الحاجة إلى البحث عنها في جدول البيانات الوصفية.

لاستخدام الأداة Identify features مع الطبقات المتجهية، اتبع الخطوات التالية:

  1. حدد الطبقة المتجهية في لوحة الطبقات.

  2. انقر على الأداة Identify features في شريط الأدوات أو اضغط Ctrl+Shift+I.

  3. انقر على معلم في عرض الخريطة.

../../../_images/identify_features.png

شكل 12.81 نافذة نتائج التعريف

تعرض لوحة Identify results معلومات المعالم المختلفة في عرض شجري. تحتوي اللوحة على عمودين: Feature و Value. العنصر الأول هو اسم الطبقة، وعناصره الفرعية هي المعلم (المعالم) الذي جرى تعريفه. يُعرَّف كل معلم بحقل اسم العرض مع قيمته. وتليه معلومات أخرى عن المعلم:

  • القسم Derived (المشتق) - وهي المعلومات المحسوبة أو المشتقة من معلومات أخرى في الطبقة، مثل مساحة مضلع أو طول خط. ومن المعلومات العامة التي يمكن إيجادها في هذا القسم:

    • تبعًا لنوع الشكل الهندسي، القياسات الديكارتية للطول أو المحيط أو المساحة بوحدات نظام الإحداثيات المرجعي (CRS) للطبقة. وبالنسبة للخطوط المتجهية ثلاثية الأبعاد، يتوفر الطول الديكارتي للخط.

    • تبعًا لنوع الشكل الهندسي، وإذا كان هناك مجسم إهليلجي (ellipsoid) مضبوط في نافذة Project Properties (General ► Measurements)، القيم الإهليلجية للطول أو المحيط أو المساحة بالوحدات المحددة.

    • عدد أجزاء الشكل الهندسي في المعلم ورقم الجزء الذي نُقر عليه.

    • عدد الرؤوس في المعلم.

    • معلومات الإحداثيات، باستخدام إعدادات Coordinates display في خصائص المشروع:

      • قيم الإحداثيين X و Y للنقطة التي نُقر عليها

      • رقم أقرب رأس إلى النقطة التي نُقر عليها

      • قيم الإحداثيين X و Y لأقرب رأس (و Z/M إن وُجدت)

      • إذا نقرت على قطعة منحنية، يُعرض أيضًا نصف قطر ذلك المقطع.

      • إذا كان لكل من الطبقة المتجهية والمشروع مرجع رأسي (vertical datum) مضبوط وكانا مختلفين، فستُعرض القيمة Z لكلا المرجعين.

  • Actions (الإجراءات): يمكن إضافة إجراءات إلى نوافذ تعريف المعالم. يُنفَّذ الإجراء بالنقر على تسميته. افتراضيًا، يُضاف إجراء واحد فقط هو View feature form للتحرير. ويمكنك تعريف مزيد من الإجراءات في نافذة خصائص الطبقة (انظر خصائص الإجراءات).

  • Data attributes (البيانات الوصفية): وهي قائمة حقول البيانات الوصفية وقيمها للمعلم الذي نُقر عليه.

    ملاحظة

    تكون الروابط الموجودة في البيانات الوصفية للمعلم قابلة للنقر من لوحة Identify Results، وتُفتح في متصفح الويب الافتراضي لديك.

  • عندما تكون للطبقة المتجهية علاقات معرّفة، يمكن للوحة Identify Results عرض المعالم المرتبطة المُشار إليها و المُشيرة كلتيهما. لعرض هذه العلاقات، تأكد من تفعيل الخيار Show relations في إعدادات التعريف. تتضمن المعلومات المتاحة لكل معلم مرتبط ما يلي:

    • اسم العلاقة والطبقة المرتبطة

    • القيمة في الحقل المُشار إليه أو المُشير، التي تعرّف المعلم

    • الإجراءات المفعّلة

    • قائمة حقول البيانات الوصفية وقيمها

    يمكنك توسيع المعالم المرتبطة لاستكشاف السجلات المتصلة عبر مستويات متعددة، بما في ذلك علاقات متعدد إلى متعدد (n:m) والعلاقات متعددة الأشكال (polymorphic). لا تُحمَّل إلا العقد التي توسّعها صراحةً، مما يمنع التداخل المفرط.

    للتركيز على سجل مرتبط بعينه، انقر عليه بالزر الأيمن واختر Identify Feature. يؤدي ذلك إلى إعادة تمركز نتائج التعريف على المعلم المحدد، وبدء شجرة تعريف جديدة منه، مما يحدّ فعليًا من عمق التداخل الظاهر. وتُستبعد تلقائيًا المعالم المعروضة سابقًا في العقد الأصلية لتجنب التكرار أو العلاقات الدائرية.