2.2. درس: إضافة طبقاتك الأولى

سنبدأ بتشغيل التطبيق، وإنشاء خريطة أساسية نستخدمها في الأمثلة والتمارين.

هدف هذا الدرس: البدء بخريطة مثال.

ملاحظة

قبل البدء بهذا التمرين، يجب أن يكون QGIS مثبتًا على حاسوبك. ويجب أيضًا أن تكون قد نزّلت البيانات النموذجية لاستخدامها.

شغّل QGIS من اختصار سطح المكتب، أو من عنصر القائمة، أو غير ذلك، بحسب الطريقة التي ضبطت بها تثبيته.

ملاحظة

التُقطت لقطات الشاشة في هذه الدورة باستخدام QGIS 3.4 على نظام Linux. وبحسب إعداداتك، قد تبدو الشاشات التي تراها مختلفة بعض الشيء. ومع ذلك، ستظل الأزرار نفسها متاحة، وستعمل التعليمات على أي نظام تشغيل. ستحتاج إلى QGIS 3.4 (أحدث إصدار وقت كتابة هذا الدليل) لاستخدام هذه الدورة.

دعونا نبدأ على الفور!

2.2.1. ★☆☆ تابع معنا: تحضير خريطة

  1. افتح QGIS. سيكون لديك خريطة جديدة فارغة.

    ../../../_images/add_blank_qgis.png
  2. تتيح لك نافذة الحوار Data Source Manager اختيار البيانات المراد تحميلها بحسب نوع البيانات. سنستخدمها لتحميل مجموعة بياناتنا: انقر على الزر dataSourceManager Open Data Source Manager.

    إذا لم تجد الأيقونة، فتحقق من تفعيل شريط الأدوات Data Source Manager في القائمة View ► Toolbars.

    ../../../_images/add_data_dialog.png
  3. حمّل مجموعة البيانات المتجهية protected_areas.shp:

    1. انقر على التبويب Vector.

    2. فعّل نوع المصدر radioButtonOnFile.

    3. اضغط الزر ... بجوار Vector Dataset(s).

    4. اختر الملف exercise_data/shapefile/protected_areas.shp في مجلد التدريب الخاص بك.

    5. انقر على Open. سترى نافذة الحوار الأصلية وقد مُلئ فيها مسار الملف.

      ../../../_images/add_vector_dialog.png
    6. انقر على Add هنا أيضًا. ستُحمَّل الآن البيانات التي حددتها: يمكنك رؤية عنصر protected_areas في اللوحة Layers (أسفل اليسار) مع عرض معالمه في لوحة الخريطة الرئيسية.

      ../../../_images/first_loaded_layer.png

تهانينا! لديك الآن خريطة أساسية. الآن سيكون الوقت المناسب لإنقاذ عملك.

  1. انقر على الزر Save As: fileSaveAs

  2. احفظ الخريطة في مجلد solution بجوار exercise_data وسمِّها basic_map.qgz.

2.2.2. ★☆☆ جرّب بنفسك:

كرّر الخطوات أعلاه لإضافة الطبقتين places.shp و rivers.shp من المجلد نفسه (exercise_data/shapefile) إلى الخريطة.

2.2.3. ★☆☆ تابع معنا: تحميل بيانات متجهية من قاعدة بيانات GeoPackage

تتيح لك قواعد البيانات تخزين حجم كبير من البيانات المترابطة في ملف واحد. وقد تكون على دراية بالفعل بنظام لإدارة قواعد البيانات (DBMS) مثل Libreoffice Base أو MS Access. ويمكن لتطبيقات نظم المعلومات الجغرافية (GIS) أيضًا الاستفادة من قواعد البيانات. ولأنظمة إدارة قواعد البيانات الخاصة بنظم المعلومات الجغرافية (مثل PostGIS) وظائف إضافية، لأنها تحتاج إلى التعامل مع البيانات المكانية.

الصيغة المفتوحة GeoPackage هي حاوية تتيح لك تخزين بيانات نظم المعلومات الجغرافية (الطبقات) في ملف واحد. وعلى عكس صيغة ESRI Shapefile (مثل مجموعة البيانات protected_areas.shp التي حمّلتها سابقًا)، يمكن لملف GeoPackage واحد أن يحتوي على بيانات متنوعة (متجهية وشبكية) بأنظمة إحداثيات مرجعية مختلفة، بالإضافة إلى جداول بلا معلومات مكانية؛ وتتيح لك كل هذه الميزات مشاركة البيانات بسهولة وتجنب تكرار الملفات.

لتحميل طبقة من GeoPackage، ستحتاج أولًا إلى إنشاء اتصال به:

  1. انقر على الزر dataSourceManager Open Data Source Manager.

  2. على اليسار، انقر على التبويب newGeoPackageLayer GeoPackage.

  3. انقر على الزر New وانتقل إلى الملف training_data.gpkg في المجلد exercise_data الذي نزّلته سابقًا.

  4. اختر الملف واضغط Open. أُضيف مسار الملف الآن إلى قائمة اتصالات Geopackage، ويظهر في القائمة المنسدلة.

أنت الآن جاهز لإضافة أي طبقة من ملف GeoPackage هذا إلى QGIS.

  1. انقر على الزر Connect. يُفترض أن ترى الآن في الجزء الأوسط من النافذة قائمة بجميع الطبقات الموجودة في ملف GeoPackage.

  2. اختر الطبقة roads وانقر على الزر Add.

    ../../../_images/add_data_dialog_geopackage.png

    تُضاف طبقة roads إلى اللوحة Layers مع عرض معالمها على لوحة الخريطة.

  3. انقر على Close.

تهانينا! لقد حمّلت أول طبقة من GeoPackage.

2.2.4. ★☆☆ تابع معنا: تحميل بيانات متجهية من قاعدة بيانات SpatiaLite باستخدام المستعرض

يوفر QGIS إمكانية الوصول إلى صيغ قواعد بيانات أخرى كثيرة. ومثل GeoPackage، فإن صيغة قاعدة بيانات SpatiaLite امتداد لمكتبة SQLite. وتتبع إضافة طبقة من مزوّد SpatiaLite القواعد نفسها الموضحة أعلاه: أنشئ الاتصال --> فعّله --> أضف الطبقة (أو الطبقات).

مع أن هذه إحدى طرق إضافة بيانات SpatiaLite إلى خريطتك، لنستكشف طريقة أخرى فعّالة لإضافة البيانات: Browser.

  1. انقر على الأيقونة dataSourceManager لفتح النافذة Data Source Manager.

  2. انقر على التبويب fileOpen Browser.

  3. في هذا التبويب يمكنك رؤية جميع أقراص التخزين المتصلة بحاسوبك، بالإضافة إلى مدخلات لمعظم التبويبات الموجودة على اليسار. تتيح هذه المدخلات وصولًا سريعًا إلى قواعد البيانات أو المجلدات المتصلة.

    على سبيل المثال، انقر على أيقونة القائمة المنسدلة بجوار المدخل geoPackage GeoPackage. سترى الملف training-data.gpkg الذي اتصلنا به سابقًا (وطبقاته، إذا وسّعته).

  4. انقر بزر الفأرة الأيمن على المدخل spatialite SpatiaLite واختر New Connection....

  5. انتقل إلى المجلد exercise_data، واختر الملف landuse.sqlite وانقر على Open.

    لاحظ أن مدخلًا باسم dbSchema landuse.sqlite قد أُضيف تحت المدخل SpatiaLite.

  6. وسّع المدخل dbSchema landuse.sqlite.

  7. انقر نقرًا مزدوجًا على الطبقة polygonLayer landuse أو حدّدها واسحبها وأفلتها على لوحة الخريطة. تُضاف طبقة جديدة إلى اللوحة Layers وتُعرض معالمها على لوحة الخريطة.

    ../../../_images/spatialite_dialog_connected.png

نصيحة

فعّل اللوحة Browser من View ► Panels ► واستخدمها لإضافة بياناتك. إنها اختصار مفيد للتبويب Data Source Manager ► Browser، وتؤدي الوظيفة نفسها.

ملاحظة

تذكّر أن تحفظ مشروعك بشكل متكرر! لا يحتوي ملف المشروع على أي من البيانات نفسها، لكنه يتذكر الطبقات التي حمّلتها في خريطتك.

2.2.5. ★★☆ جرّب بنفسك: تحميل مزيد من البيانات المتجهية

حمّل مجموعات البيانات التالية من المجلد exercise_data إلى خريطتك باستخدام أي من الطرق الموضحة أعلاه:

  • buildings

  • water

2.2.6. تابع معنا: إعادة ترتيب الطبقات

تُرسم الطبقات الموجودة في قائمة الطبقات على الخريطة بترتيب معين. فالطبقة الموجودة في أسفل القائمة تُرسم أولًا، والطبقة الموجودة في أعلاها تُرسم أخيرًا. وبتغيير ترتيب ظهورها في القائمة، يمكنك تغيير ترتيب رسمها.

ملاحظة

يمكنك تغيير هذا السلوك باستخدام مربع الاختيار Control rendering order أسفل اللوحة Layer Order. لكننا لن نناقش هذه الميزة الآن.

على الأرجح أن الترتيب الذي حُمّلت به الطبقات في الخريطة ليس منطقيًا في هذه المرحلة. ومن المحتمل أن تكون طبقة الطرق مخفية تمامًا لأن طبقات أخرى تعلوها.

على سبيل المثال، هذا الترتيب للطبقات...

../../../_images/incorrect_layer_order.png

... سيؤدي إلى إخفاء الطرق والأماكن لأنها تمتد أسفل مضلعات طبقة استخدامات الأراضي.

لحل هذه المشكلة:

  1. انقر على طبقة في قائمة الطبقات واسحبها.

  2. أعد ترتيبها لتبدو كما يلي:

../../../_images/correct_layer_order.png

سترى أن الخريطة أصبحت الآن أكثر منطقية بصريًا، إذ تظهر الطرق والمباني فوق مناطق استخدامات الأراضي.

2.2.7. الخلاصة

لقد أضفت الآن جميع الطبقات التي تحتاجها من عدة مصادر مختلفة وأنشأت خريطة أساسية!

2.2.8. ما التالي؟

أصبحت الآن على دراية بالوظيفة الأساسية للزر Open Data Source Manager، ولكن ماذا عن بقية الأزرار؟ كيف تعمل هذه الواجهة؟ قبل أن نتابع، لنلقِ نظرة على بعض أساليب التفاعل الأساسية مع واجهة QGIS. وهذا هو موضوع الدرس التالي.